Back to overview
Downtime
Forum maintenance
Jan 26 at 08:27pm CET
Affected services
Scratch Forums
Resolved
Jan 27 at 11:28am CET
Resolved!
Affected services
Scratch Forums
Created
Jan 26 at 08:27pm CET
The Scratch Team is currently working on the forums. Expect undefined downtime.
Affected services
Scratch Forums